Are you a mom? Want to talk about mom things? Or talk about anything? Send me an email and lets chat! .

Saturday, February 14, 2009

Well, I guess both myelf *and* my GYN were wrong...

Because apparently I don't have a Kidney infection. Which is probably why the antibiotics haven't been doing anything since Wednesday, and why I feel worse and I'm constantly in pain.

Apparently I have kidney stones!!!! That's currently what my Primary doctor thinks, at least. I was there to see him bright and early at 8:00 a.m., and after explaining everything to him, he asked if I had ever heard of Kidney stones and I knew I'd be in for trouble!!

A few years ago, my OB/GYN found stones during an U/S to check for something else... He told me that they can kind of just hang out there in your body for a long time, and they shouldn't cause much pain, but that at any random time, they can just flare up and be hell!

So now I have to go in for a Spiral CT Scan on Tuesday to see what's going on, and I have to drop off a Urine sample at the Lab Monday morning. And then the Dr will see if I'll be able to pass them myself, or if I'll need surgery. Damn it!!

I swear, lately I cannot go to the Dr without ending up with something really stupid, something that I totally didn't plan on going in there for. So now I'm wondering if the last 'Bladder Infection' I had, about 6 mths ago, that my GYN put me on antibiotics for but came back right away again, was really the stones acting up.....

So we'll see what happens~


Bloggymommy said...

OH NO!!! That really sucks! I don't know why none of us thought about that considering you were telling us how much pain you were in! I really hope you start to feel better soon!